Aktia Open Banking - Major outage affecting Payment Initiation Services

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted May 24, 2026 - 15:02 EEST

Identified

We are currently investigating an issue with Aktia.

- Affected users:  100 %
- Affected flow:  Payment Initiation flow
- Start Time:  24/05/2026 07:30 CET
- Bank side error: cancelled payment flow
- Provider name:  fi-aktia-ob
Posted May 24, 2026 - 10:37 EEST
This incident affected: Aktia.