Samlink Group - Open Banking - Major outage affecting Payment Initiation services

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Aug 24, 2025 - 14:53 UTC

Investigating

We are currently investigating an issue with Samlink Group.
Posted Aug 24, 2025 - 06:59 UTC
This incident affected: Oma Säästöpankki, POP Pankki, and Säästöpankki.