Nordea - Degraded Performance

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 13, 2026 - 19:03 EEST

Investigating

We are currently investigating an issue with Nordea.

- Affected users:  30%
- Affected flow: Payment Initiation  flow
- Start Time:  13/06/2026 16:50 CET
- Bank side error: cancelled payments
- Provider name:  fi-nordea-oauth2
Posted Jun 13, 2026 - 18:12 EEST
This incident affected: Nordea.