S-Pankki | Open Banking | Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Finland

Resolved

This incident has been resolved.
Posted Feb 25, 2026 - 13:15 EET

Identified

We have identified the issue and we will update when a significant change to the situation occurs.

- Affected users: ~99%
- Affected flow: payments, refresh
- Start Time: 11AM
- Bank side error: HTTP 503 Service Unavailable
- Provider name: fi-spankki-ob
Posted Feb 25, 2026 - 12:13 EET
This incident affected: S-Pankki.