Samlink Group - Open Banking - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Finland

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 08:28 UTC

Identified

We have identified the bank-side issue and contacted the bank. We will update when a significant change to the situation occurs.
Posted Mar 23, 2025 - 07:05 UTC
This incident affected: Oma Säästöpankki, POP Pankki, and Säästöpankki.