Nordea Outage

Incident Report for Tink providers Finland

Resolved

This incident has been resolved.
Posted 6 days ago. Apr 01, 2025 - 04:24 UTC

Investigating

Investigating - Tink automatic monitoring service has detected a service outage. Affected flow(s): manual refresh.
Posted 6 days ago. Mar 31, 2025 - 20:23 UTC
This incident affected: Nordea.