Aktia - Major outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Sep 13, 2026 - 18:39 EEST

Investigating

- Affected users: 100%
- Affected flow: Payments
- Start Time: 12.09.2026 21:30
- Bank side error: timeouts
- Provider name: fi-aktia-ob
Posted Sep 12, 2026 - 23:01 EEST
This incident affected: Aktia.