OP Open Banking - Degraded performance in Payment Initiation services

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Aug 26, 2025 - 19:49 UTC

Monitoring

The service is currently recovering and we are actively monitoring the situation.
Posted Aug 26, 2025 - 19:30 UTC

Investigating

We are currently investigating an issue with OP Bank.
Posted Aug 26, 2025 - 19:27 UTC
This incident affected: OP.