Nordea Open Banking - Manual authentication - Partial Outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Mar 20, 2026 - 10:13 EET

Investigating

We are currently investigating an issue with Nordea.

- Affected users: 90%
- Affected flow: Manual authentication
- Start Time: 19/03/2026 [19:00] CET
- Bank side error: Errors Authentication endpoint.
- Provider name: dk-nordea-ob, fi-nordea-ob, no-nordea-ob
Posted Mar 19, 2026 - 20:48 EET
This incident affected: Nordea.