Nordea Open Banking - Major outage affecting Account Information and Payment Initiation

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Apr 02, 2025 - 11:33 UTC

Identified

This issue has been increased to Major outage affecting Account Information and Payment Initiation.

We have identified the issue and we will update when a significant change to the situation occurs.
Posted Apr 02, 2025 - 11:05 UTC

Investigating

Investigating - Tink automatic monitoring service has detected a service outage. Affected flow(s): authentication.
Posted Apr 02, 2025 - 10:52 UTC
This incident affected: Nordea.