S-Pankki - Partial outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 08, 2026 - 08:29 EEST

Identified

We have identified the issue and we will update when a significant change to the situation occurs.

- Affected users: [50]%
- Affected flow: Payments
- Start Time: 17:30 CEST
- Provider name: fi-spankki-ob
- Bank side error: 500s responses
Posted Jun 07, 2026 - 19:12 EEST
This incident affected: S-Pankki.