OPBank Open Banking - Major Outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Mar 05, 2026 - 09:24 EET

Update

We are continuing to investigate this issue.
Posted Mar 05, 2026 - 06:25 EET

Investigating

We are currently investigating an issue with OPBank

- Affected users: 100%
- Affected flow: Manual authentication | Payment Initiation
- Start Time: 05:00
- Bank side error: server error in callback
- Provider name: fi-opbank-ob
Posted Mar 05, 2026 - 06:20 EET
This incident affected: OP.