Nordea - Issue with payments
Incident Report for Tink providers Finland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Jul 04, 2022 - 09:10 UTC
Identified
We have identified the issue and are in contact with Nordea for further information.
We will update when a significant change to the situation occurs.
Posted Jul 03, 2022 - 14:30 UTC
This incident affected: Nordea.