Säästöpankki - Major outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Dec 14, 2025 - 17:01 EET

Investigating

We are currently investigating an issue with Säästöpankki.

- Affected users: 80%
- Affected flow: payment initiation & authentication
- Start Time: 14/12/2025 12:00 CET
- Bank side error: Timeouts after failed authentication
- Provider name: fi-saastopankki-ob
Posted Dec 14, 2025 - 14:26 EET
This incident affected: Säästöpankki.