N26 Open Banking - Partial Outage affecting Account Information Service
Incident Report for Tink providers Finland
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 10:24 UTC
Identified
We have identified the issue and we will update when a significant change to the situation occurs.
Posted Jan 17, 2025 - 12:28 UTC
This incident affected: N26.