Nordea - Partial outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted May 04, 2026 - 22:47 EEST

Identified

We have identified the issue and we will update when a significant change to the situation occurs.
- Affected users: ~80%
- Affected flow: Payment initiation flow, Manual refresh
- Start Time: 04/05/2026 18:20 CEST
- Provider name: fi-nordea-oauth2
Posted May 04, 2026 - 20:00 EEST
This incident affected: Nordea.