Nordea Open Banking - Payment Initiation Services Degraded Performance

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 04, 2025 - 08:46 UTC

Investigating

We are currently investigating an issue with Nordea.
Posted Jun 04, 2025 - 08:01 UTC
This incident affected: Nordea.