Partial Outage for the Payment Service for several banks

Incident Report for Tink providers Finland

Resolved

This issue has been resolved. We apologize for the inconvenience.
Posted Jul 16, 2026 - 15:15 EEST

Investigating

We are currently investigating an issue with Nordea, S-Pankki, Aktia, Pop Pankki.

- Affected users: ~50%
- Affected flow: PIS
- Start Time: 2026-07-16 10:55
- Bank side error: Rejected error
- Provider name: fi-nordea-oauth2, fi-spankki-ob, fi-aktia-ob, fi-poppankki-ob
Posted Jul 16, 2026 - 14:20 EEST
This incident affected: Aktia, Nordea, POP Pankki, and S-Pankki.