American Express - Major Outage
Incident Report for Tink providers Finland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Nov 06, 2024 - 09:26 UTC
Investigating
We are currently investigating an issue with American Express.
Posted Nov 05, 2024 - 12:52 UTC
This incident affected: American Express.