Samlink Group Open Banking - Payment Service Partial Outage

Incident Report for Tink providers Finland

Resolved

This incident has been resolved.
Posted Feb 12, 2026 - 17:16 EET

Identified

We are currently investigating an issue with Samlink.
Posted Feb 12, 2026 - 11:20 EET

Monitoring

The service is currently recovering and we are actively monitoring the situation.
Posted Feb 12, 2026 - 11:10 EET

Identified

Samlink Group Open Banking - Payment Service Partial Outage

We are currently investigating an issue with Samlink.
- Affected users: 50 %
- Affected flow: Payment Initiation flow
- Start Time: 12/02/2026 09:05 CET
- Bank side error: stuck in status endpoint
- Provider name: fi-saastopankki-ob, fi-poppankki-ob, fi-omasp-ob
Posted Feb 12, 2026 - 11:10 EET
This incident affected: Oma Säästöpankki, POP Pankki, and Säästöpankki.