POP Pankki - Major Outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 15, 2026 - 23:15 EEST

Investigating

We are currently investigating an issue with POP Pankki.

- Affected users:  100 %
- Affected flow: Payment Initiation,  Authentication flows
- Start Time:  15/06/2026 20:10 CET
- Bank side error: cancelled payment flow
- Provider name:  fi-poppankki-ob
Posted Jun 15, 2026 - 21:28 EEST
This incident affected: POP Pankki.