OP Open Banking - Major Outage affecting Payment Initiation
Incident Report for Tink providers Finland
Resolved
This incident has been resolved.
Posted Jan 02, 2024 - 17:24 UTC
Identified
We have identified the issue and are in contact with OP for further information.
We will update when a significant change to the situation occurs.
Posted Jan 02, 2024 - 16:16 UTC
This incident affected: OP.