Nordea - Major Outage

Incident Report for Tink providers Finland

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 05:19 EEST

Update

We are continuing to investigate this issue.
Posted Apr 12, 2026 - 04:20 EEST

Investigating

Investigating - Tink automatic monitoring service has detected a service outage.

- Affected users: 100%
- Affected flow: Payments
- Start Time: 03:00 CEST
- Bank side error: Bank rejected payments, marking them as invalid
- Provider name: fi-nordea-oauth2
Posted Apr 12, 2026 - 04:17 EEST
This incident affected: Nordea.