Aktia OB - AIS Major outage
Incident Report for Tink providers Finland
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 07:39 UTC
Identified
We have identified the issue and are in contact with Aktia for further information. Account information services is unavailable from 13:00 CET.
We will update when a significant change to the situation occurs.
Posted Mar 16, 2024 - 13:10 UTC
This incident affected: Aktia.