Nordea - AIS and PIS Outage

Incident Report for Tink providers Finland

Resolved

The issue has been resolved. We apologize for this inconvenience.
Posted Jun 12, 2026 - 22:11 EEST

Investigating

We are currently investigating an issue with Nordea.

- Affected users:  80%
- Affected flow: Manual authentication, Payment Initiation flows
- Start Time: 12/06/2026 16:55 CET
- Bank side error: multiple issues
- Provider name:  fi-nordea-oauth2
Posted Jun 12, 2026 - 18:30 EEST
This incident affected: Nordea.