OP Bank Open Banking - Major outage affecting Account Information and Payment Initiation
Incident Report for Tink providers Finland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Dec 29, 2023 - 12:07 UTC
Identified
We have identified the issue and are in contact with OP Bank for further information.
We will update when a significant change to the situation occurs.
Posted Dec 29, 2023 - 11:26 UTC
This incident affected: OP.