S-Pankki OB - Payments outage
Incident Report for Tink providers Finland
Resolved
The issue has been resolved. We apologize for this inconvenience.
Posted Nov 17, 2022 - 15:52 UTC
Identified
We have identified the issue and are in contact with S-Pankki for further information.
We will update when a significant change to the situation occurs.
Posted Nov 17, 2022 - 08:04 UTC
This incident affected: S-Pankki.